OCI8 és PHP linux alatt

A VIK Wikiből
A lap korábbi változatát látod, amilyen (vitalap) 2012. október 21., 21:21-kor történt szerkesztése után volt. (Új oldal, tartalma: „{{GlobalTemplate|Infoalap|SzgLab5PHPLinux}} Az oracle támogatáshoz Debian alatt sajnos újra kell forgatni a php-t. A http://hu.php.net/manual/hu/ref.oci8.php alatt…”)
(eltér) ← Régebbi változat | Aktuális változat (eltér) | Újabb változat→ (eltér)
Ugrás a navigációhoz Ugrás a kereséshez

Ez az oldal a korábbi SCH wiki-ről lett áthozva. Az eredeti változata itt érhető el.

Ha úgy érzed, hogy bármilyen formázási vagy tartalmi probléma van vele, akkor kérlek javíts rajta egy rövid szerkesztéssel.

Ha nem tudod, hogyan indulj el, olvasd el a migrálási útmutatót


Az oracle támogatáshoz Debian alatt sajnos újra kell forgatni a php-t. A http://hu.php.net/manual/hu/ref.oci8.php alatt az egyik hozzászólásban némely dolog részletesebben le van írva, ajánlott azt is megnézni, én is onnan vágtam ide a dolgok egy részét.

Az újrafordítás nálam kb. az alábbiak szerint ment. Persze mindent csak ésszel futtassatok.

# apt-get install php4-dev apache-dev libbz2-dev libcurl3-dev libxslt1-dev libt1-dev libgd-gif1-dev \
libc-client-dev libldap2-dev libmcal0-dev libmhash-dev libmysqlclient10-dev librecode-dev freetds-dev  \
libsablot0-dev libzzip-dev odbcinst1 unixodbc unixodbc-dev

Elég sok sajnos, de a fordításhoz kellenek. A megfelelő opciók átállításával biztos kikapcsolhatóak.

# cd /usr/src
# apt-get source php4 

(A /etc/sources.list -et megfelelő beállításaival persze.)

# export ORACLE_HOME=/home/miki/local/oracle/product/10.2.0/client_1/
# export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$ORACLE_HOME/lib
# export LD_PRELOAD=libclntsh.so.10.1

# cat /etc/ld.so.conf
/usr/X11R6/lib
/home/.../local/oracle/product/10.2.0/client_1/lib/

Nekem itt a második sort kellett felvenni.

# ldconfig
# cd /usr/src/php4-4.3.10 (jelenleg)
# vi debian/rules

Itt a COMMON_CONFIG részhez kell hozzáadni a "--with-oci8" opciót.

# debchange -i

Ezzel lehet növelni a kiadás verziószámát, így a dpkg frissíteni fogja a rendszeren lévő csomagokat.

# debian/rules binary

Az így kapott csomagokat pedig már csak fel kell telepíteni.

# cd ..
# dpkg -i *.deb

Ezekkel azonban a következőre jutottam:

Warning:  ocilogon(): _oci_open_server: Error while trying to retrieve text for error ORA-12541
 in .../public_html/lab6/in.php on line 10

Ha van ötleted írj.

B terv

Alternatív megoldás az shfs modul. Debian alatt a következő:

# apt-get install shfs-source
# cd /usr/src
# tar -xvjf shfs.tar.bz2  
# cd modules/shfs
# make
# make install
# modprobe shfs
# mkdir /mnt/rapid
# shfsmount -o uid=1000,gid=1000 NEPTUNKOD@rapid.eik.bme.hu /mnt/rapid

Az =Uid= és =gid= tetszés szerint beállítandó. Ezután helyi szövegszerkesztővel lehet szerkeszteni a rapid-on lévő fájlokat.


-- palacsint - 2006.03.23.