„Adatlab SOA PyCharm” változatai közötti eltérés

A VIK Wikiből
Ugrás a navigációhoz Ugrás a kereséshez
(Windowsos környezet, have fun)
15. sor: 15. sor:
  
 
== Környezet beállítása Arch Linuxon ==
 
== Környezet beállítása Arch Linuxon ==
(Akinek más rendszere van és érzi magában az erőt, vegyen fel hasonló blokkot a saját rendszere beállítási útmutatójával)
 
 
* Telepítsd az Oracle klienst eszerint: [https://wiki.archlinux.org/index.php/Oracle_client#Method_1:_Unofficial_repository archwiki]
 
* Telepítsd az Oracle klienst eszerint: [https://wiki.archlinux.org/index.php/Oracle_client#Method_1:_Unofficial_repository archwiki]
 
* Telepítsd a pip2-t a [https://www.archlinux.org/packages/extra/any/python2-pip/ python2-pip] csomaggal.
 
* Telepítsd a pip2-t a [https://www.archlinux.org/packages/extra/any/python2-pip/ python2-pip] csomaggal.
 
* pip2-vel telepítsd a <code>flask</code>, <code>requests</code>, <code>cx_oracle</code> csomagokat (ha van hiányzó függőséged, kiírja)
 
* pip2-vel telepítsd a <code>flask</code>, <code>requests</code>, <code>cx_oracle</code> csomagokat (ha van hiányzó függőséged, kiírja)
 +
 +
== Környezet beállítása Windowson ==
 +
* Telepítsd a Python 2.7-es verióját Windowsra: [https://www.python.org/downloads/release/python-2713/ python.org]
 +
* Nyisd meg Parancssorban a <code>\Python\mappa\Scripts</code>-et
 +
* a <code>pip2 install <modul></code> paranccsal telepítsd a következő modulokat: <code>flask</code>, <code>requests</code>
 +
* Töltsd le a <code>cx_Oracle</code> modult [https://pypi.python.org/pypi/cx_Oracle/5.3 innen] és telepítsd (Windows, Python 2.7)
 +
* Töltsd le az Oracle Instant Client-et a hivatalos honlapról: [http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html oracle.com] [http://www.mediafire.com/file/7f8w27kbhfw4rc4/instantclient_12_2.zip mirror]
 +
** Válaszd ki a te rendszerednek megfelelő verziót, fogadd el a licenszt!
 +
** A <code>Basic</code> és az <code>SDK</code> verziók kellenek. A letöltéshez regisztráció szükséges.
 +
** Csomagold ki mindkét <code>.zip</code>-et (egy mappát kell kapj).
 +
* A kapott mappa teljes tartalmát másold a <code>\Python\mappa\Lib\site-packages</code> mappába.
  
 
Használt PyCharm verzió: 2017.1 Professional
 
Használt PyCharm verzió: 2017.1 Professional

A lap 2017. március 31., 09:27-kori változata

Ez egy útmutató az PyCharm beállításáról az Adatbázisok laboratórium tárgy negyedik, SOA méréséhez. A cél, hogy saját gépen tudd az alkalmazást fejleszteni és futtatni. A leírtakért felelősséget nem vállalok, készíts biztonsági mentést mindenről, mielőtt nekilátsz.

Project letöltése és beállítása

  • Végezd el a hallgatói útmutató alapján az alkalmazásod összerakását a rapidon (Ez a „Környezet kialakítása a Rapid szerveren” rész)
  • Töltsd le a teljes soa mappát tetszőleges módszerrel (scp, WinSCP, stb.)
  • Haladj végig a hivatalos útmutatón a függőségek lokális telepítéséhez. (Debian/Ubuntu)
    • Ha más rendszered van lent keresd a függőségek telepítésének módját!
  • PyCharmból nyisd meg a soa mappát
  • A PyCharm beépített Terminal funkciójával futtasd a következő parancsot a soa mappából: python2 service.py
  • Ezután minden változtatáskor újratölt a webservice. Hiba esetén a Terminalban látod a hiba okát, ekkor kézzel kell újraindítani a szervert a fenti parancs kiadásával.

Project feltöltése

  • Töltsd fel a soa mappát rapidra
  • Próbáld ki ott is az appodat!

Környezet beállítása Arch Linuxon

  • Telepítsd az Oracle klienst eszerint: archwiki
  • Telepítsd a pip2-t a python2-pip csomaggal.
  • pip2-vel telepítsd a flask, requests, cx_oracle csomagokat (ha van hiányzó függőséged, kiírja)

Környezet beállítása Windowson

  • Telepítsd a Python 2.7-es verióját Windowsra: python.org
  • Nyisd meg Parancssorban a \Python\mappa\Scripts-et
  • a pip2 install <modul> paranccsal telepítsd a következő modulokat: flask, requests
  • Töltsd le a cx_Oracle modult innen és telepítsd (Windows, Python 2.7)
  • Töltsd le az Oracle Instant Client-et a hivatalos honlapról: oracle.com mirror
    • Válaszd ki a te rendszerednek megfelelő verziót, fogadd el a licenszt!
    • A Basic és az SDK verziók kellenek. A letöltéshez regisztráció szükséges.
    • Csomagold ki mindkét .zip-et (egy mappát kell kapj).
  • A kapott mappa teljes tartalmát másold a \Python\mappa\Lib\site-packages mappába.

Használt PyCharm verzió: 2017.1 Professional